L'annuaire des forums Forumactif
votre référence en terme de référencement et de développement de forums.
 


Aller à la page : Précédent  1, 2, 3  Suivant


 Demande de Profil [SeLfde4Th7]

SeLfde4Th7ModérateurCodeur en chef
Messages : 2572
Oh, j'ai tout cassé !! Mr.Red

Ça doit être les commentaires, je les ai enlevés dans le code ci dessous Wink:
Code:
<!--Script des profils-->
           <script type="text/javascript">
           $(function(){
                   var i = $('.online').find('img').length;
     if(i == 2){
         $('.i_icon_offline').css('display', 'block');
     };
                  
     $('.profil-detail').each(function(){
         var h = $(this).text().match(/^Humeur/);
             if(h == 'Humeur'){
                 var src = $(this).find('img').attr('src');
                 var title = $(this).find('img').attr('title');
                 $(this).parent().prepend('<span class="humeur"><img src="'+src+'" title="'+title+'" /></span>');
                 $(this).remove();
             }

             var e = $(this).find('img');
                   var span = $(e).prev().width();
         var width = $(this).find('img').width()+span;
         var img = $(this).find('img').attr('src');
         if(img != ''){
             $(e).parent().css({'width':''+width+'','display':'inline-block','margin-left':'5px'});
         }
                  
                           var l = $(this).find('.label').find('span').text();
         if(l == 'Messages'){
             $(this).find('.label').remove();
             $(this).css({'width':'auto','display':'inline-block','margin-left':'5px'});
         }
     });
 });
           </script>
InvitéInvitéavatar
Ah c'était un test    c'est bien j'apprend des truc en même temps...
Bon bon, il y a un petit décalage que j'ai réussi à corriger et sinon petit problème chez certains membres, le nombre de messages va sur le signe astro... selon moi ca viendrait d'un autre champs qui est sensé rester en dessous... (icone avec prisme)

SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Bonjour,

Pourriez-vous demander à vos utilisateurs rencontrant le problème sur quel navigateur ils le rencontrent ?
Puis pourriez-vous afficher tout les champs pour les invités s'il vous plait ?
InvitéInvitéavatar
Le problème revient de temps à autre en actualisant (l'actualisation est longue d’ailleurs)
étant donné que ya pas grand monde en ce moment il n'y a que moi qui voit et je suis sur chrome.

et voilà qui est fait...
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Ah, je n'ai pas ce problème sur mon forum test mais sur votre forum oui Mr.Red .
On peut essayez comme ça Wink :
Code:
<!--Script des profils-->
             <script type="text/javascript">
                $(function(){
                        var i = $('.online').find('img').length;
                if(i == 2){
                    $('.i_icon_offline').css('display', 'block');
                };
                $('.profil-detail').each(function(){
                    var h = $(this).text().match(/^Humeur/);
                        if(h == 'Humeur'){
                            var src = $(this).find('img').attr('src');
                            var title = $(this).find('img').attr('title');
                            $(this).parent().prepend('<span class="humeur"><img src="'+src+'" title="'+title+'" /></span>');
                            $(this).remove();
                        }

                        var e = $(this).find('img');
                    var img = $(this).find('img').attr('src');
                    if(img != ''){
                           $(e).parent().css({'width':'auto','display':'inline-block','margin-left':'5px'});
                    }
                 
                                var l = $(this).find('.label').find('span').text();
                    if(l == 'Messages'){
                           $(this).find('.label').remove();
                           $(this).css({'width':'auto','display':'inline-block','margin-left':'5px'});
                    }
                });
         });
             </script>
InvitéInvitéavatar
Rien n'a changé à part l'histoire du bug, dans les paramètres le champs est déjà censé sauter une ligne
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Likaya a écrit:
Rien n'a changé à part l'histoire du bug, dans les paramètres le champs est déjà censé sauter une ligne

Quel bug ?
InvitéInvitéavatar

Celui ci  
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Bonjour, je n'ai plus ce bug moi !
Essayez un CTRL+F5 ...
InvitéInvitéavatar
Olala c'est bien ce que je dit je n'ai plus de problème    
Il ne reste qu'a mettre le champs (l'icone ronde avec le prisme) avec ses copains en dessous
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Oh, pardonnez moi Mr.Red.

Avec ceci ça devrait être bon Very Happy:
InvitéInvitéavatar
Un petit espace svp ?

J'essaye de comprendre un peu dans mon coin mais non comprend pas ^^ On a perdu le offline en cours de route.
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Il n'est plus dans votre template ? Sad

Remplacez le template complet par cette version (qui devrait être la version finale Very Happy) :
InvitéInvitéavatar
Bizarre...
L'image offline est toujours là même étant en ligne   
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Ce n'est pas bizarre c'est un oubli de ma part, décidément !!

Ajoutez à votre feuille de style CSS :
Code:
.i_icon_offline{
    display: none;
}
InvitéInvitéavatar
Hello,

Rien ne va plus encore, ou presque   
L'image hors ligne toujours absente et les icônes de nouveau les unes en dessous des autres.
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Ah, cette fois ce n'est point moi Very Happy .
Remplacez le template par la dernière version de celui-ci que je vous ai donné et validez de nouveau Wink .
InvitéInvitéavatar
Forcément si je met pas la bon code   
Mais offline toujours pas là
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Re,

Bien essayons d'ajouter un fadeIn, logiquement ça aurait du fonctionnait, chez moi c'est le cas Smile, bref :
InvitéInvitéavatar
Toujours pas, par contre si j'enlève
Code:
.i_icon_offline{
    display: none;
}
l'image hors ligne est là mais elle est là aussi quand on est en ligne
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Bonjour,

Pouvez-vous remettre ce code s'il vous plait ?
Je crois que le code fonctionne maintenant Wink.
InvitéInvitéavatar
Toujours pas... offline n’apparaît pas quand ce code est dans le css
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Re,

Essayez donc come ceci :
InvitéInvitéavatar
En faite, je viens de remarquer que ca fonctionne sur certaines pages et pas sur d'autres   
SeLfde4Th7ModérateurCodeur en chefavatar
Messages : 2572
Bonjour,

Pourriez-vous essayer de voir sur tout votre forum qu'est-ce qu'ont en commun, les pages sur lesquelles n'apparait pas le logo hors ligne ?
InvitéInvitéavatar
Bonne question mais franchement j'ai pas feuilletée tout le forum mais sur tout ce que j'ai feuilletée il y'en a eu que deux ou ca ne s'affichait pas... c'est pas énorme donc, c'est pas un gros problème... C'est pas non plus des pages qui doivent supporter beaucoup d'images comme la page des votes, où il n'y a que 2 petits post... Je pense qu'on peu laisser comme ca   

Il manque juste un petit espace,saut de ligne entre sexe/astro/message et l'icone ronde avec prisme et je te libère  

Aller à la page : Précédent  1, 2, 3  Suivant,
 Sujets similaires
-
» Demande de profil
» Demande de Profil [SeLfde4Th7]
» Petite demande de PA [SeLfde4Th7]
» Profil visible pendant l'écriture d'un message
» [Annulée] Demande de page d'aceuil

Répondre au sujet


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum

Modérer

Trames

  • Nos services
  • Prés. obligatoire
  • Référencé
  • Prérelance
  • 1ère relance
  • 2ème relance
  • Recherche (relance)
  • Recherche (corbeille)
  • Formulaire manquant
  • Formulaire incomplet
  • 1
  • 2
  • 3
  • 4
  • 5
  • Evaluation